Jump to content

inthis2getha

Members
  • Content Count

    19
  • Joined

  • Last visited

  • Days Won

    1

inthis2getha last won the day on October 16 2018

inthis2getha had the most liked content!

Community Reputation

1 Neutral

About inthis2getha

  • Rank
    BSCortina Newbie
  • Birthday 07/17/1977

Previous Fields

  • Ebay ID
    Inthis2getha
  • Current Car
    mk 3 XL

Profile Information

  • Gender
    Male
  • Location
    Weymouth

Recent Profile Visitors

1,020 profile views
  1. Thanks a lot guys, really appreciate the replies, Ant
  2. Thanks a lot guys, So is it best practice to change out the top ones at the same time? And are they riveted in as well? much appreciated, Ant
  3. Hey there, Looking for a bit of advice if possible please, had an advisory on my 1972 Cortina’s MOT last year : “Offside Front Lower Suspension component ball joint dust cover severely deteriorated (5.3.4 (b) (i))” I want to sort it before this years MOT so can anyone recommend good quality replacements? I see a lot of parts out there QH etc but are they actually any good?? Is it worth actually replacing the ball joints or just replace the dust covers on the current? If replacing the ball joints is it best practice to do top and bottom? Any advice very much appreciated, Thanks
  4. Thanks guys, I know silicone grease is recommended but none of the silicone grease I’ve come across actually says anything about polyurethane bushes.....except the little superflex pouches and I want/need a bigger tin/tube really! Ant
  5. Hi guys, Just wondered what grease/lubricant you use when fitting poly bushes? Google search just bring up multiple greases with pros and cons!! Just wondered what you guys use? Any help/info would be much appreciated, Thanks, Ant
  6. Thanks for the replies guys, appreciate it. Hey Craig, I have the square mounting brackets but not the tie bars, will I have any issues getting the correct ones? Also because my pfl didn’t come with arbs will the mounting holes be there? Thanks again for helping and sharing your vast knowledge 👍👍
  7. Hi folks, Any helpful advice would be much appreciated as usual, I have a pfl mk3 (1.6 XL originally) which doesn’t have ARBs, I have managed over time to get a front and rear, only problem is they are different sizes - front is 18mm and the rear is 16mm, so a few questions : 1. Is it worth fitting ARBs? 2. Do I need a matching pair or will these be fine? 3. Will they fit as there wasn’t any to start with? - (I have 2.3 v6 atlas I will be fitting soon that the rear ARB came with) many thanks in advance, Ant
  8. Hi dgo, Not sure about the speedo drive, it’s always been a bit off but just put it down to the 2L and 5speed box being fitted, maybe the Atlas will correct it.......maybe!
  9. Hey sheffieldcortinacentre, As it’s a straight swap fitting wise any idea if the drive will be very different, the atlas has 3.44 ratio but not sure what ratio my currently fitted koln has!!! Or how the ratio difference will affect drivability! Cheers, Ant
  10. Thanks a lot, that’s what I was hoping to hear 😁 I wasn’t sure whether the koln and atlas pigs heads were the same size/fitting to the prop shaft! So koln out and atlas straight in....excellent. Thanks again I really appreciate it 👍👍
  11. Hi guys, Finally got my hands on an atlas to replace my koln axle, just wondered if this was going to be a straight forward swap or hard work, will it fit straight in and bolt up or will I need a different prop or anything? It’s a 2.3 V6 atlas and I have a 1972 mk3 Cortina, 2L pinto with type 9 5 speed box and koln axle, was originally a 1.6 XL, 2L pinto and 5 speed box done before I brought it, I’m guessing the koln axle was the original 1.6 item but who knows! Any help or info would be much appreciated, thanks, Ant
  12. Sorry if Im being a bit slow here....how do I actually check the wires have power? I have a little multi meter but if the fans plugged in where do I put the pins? Cheers, Ant
  13. The horn still works, checked all the fuses, theyre ok, how can I check if the fans getting power? Ive tried unplugging it and plugging it back in but nothing!
  14. Hey guys, I posted my problems with a water pump swap the other day, thanks again for the help there, thats sorted but noticed my heater has stopped working, it was working fine before the swap, Ive checked fuses are ok, I did have a bit of coolant spray out the top hose on the heater matrix when bleeding but I had a plastic bag over the loom there, any advice would be much appreciated. Car is 1972 Mk3 Cortina originally 1600 XL now 2L pinto Thanks, Ant
×
×
  • Create New...