Jump to content
johnny boy

Swedish lefty MK2 series 2, 2 door ballast wire

Recommended Posts

1968 swedish lefty MK2 series 2.

Could anyone tell me where in the loom the ballast wires are located, are they behind the dash , or in the under bonnet loom , and what colour code are they.

I can't find them on my wiring diagram 🙄

Thanks

Share this post


Link to post
Share on other sites

Hi Johnny - will try to help at least some - the wire is completely different than any other as it is like the old fashioned "furry " type covered (presumably to contain the heat ) , seen one that was pinkish but some seem to lose the colour and look a bit grey . From what I researched years ago , the resistor wire is just a loop in the engine loom but not 100% sure about that . It also seems to matter if you have a rev counter as it is in the white wire loom from the ignition switch . I have to say that this is not proven information but what I was told many years ago - apart from the furry wire which is correct !! 

Share this post


Link to post
Share on other sites

Ok thanks for that, I have something to go on.

Unfortunately the behind dash wire loom is damaged, by the fact that the big fat brown wire from the control box  though the dash loom is melted 🙄

I've got to remove the dash loom and see if I can repair/ replace the damaged wire that are shorted together.

I will look out for the furry wire.

Thanks

Share this post


Link to post
Share on other sites

I guess I found the ballast wire, the furry one.

I had to remove the loom to repair it , as it has melted in places, so I will have to strip and repair/ replace where needed.🙄

IMG_20210528_200324_383.jpg

IMG_20210528_200407_970.jpg

IMG_20210528_200425_761.jpg

IMG_20210528_200303_385.jpg

  • Upvote 1

Share this post


Link to post
Share on other sites

I took the behind dash loom apart and replaced the big fat brown wires and a couple of earth's, that had burnt out, and checked all the others for shorting, then rewrapped it ready to put back in.

The bulkhead plugs were melted be here the fat brown wires, passed through , so I've just bypassed the connector for that wire, and will connect separately.🤔

IMG_20210704_144657_826.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...